[SRILM User List] Problem installing SRILM

Nickolay V. Shmyrev nshmyrev at yandex.ru
Tue Aug 1 14:45:49 PDT 2017

01.08.2017, 18:43, "Gary Hess" <garyhess999 at hotmail.com>:
> Hi -- I wonder if anyone can help with my installation problem. I decompressed the file "srilm-1.7.2.tar.gz" in the directory /home/gary/workspace/srilm. In the Makefile, I set "SRILM = /home/gary/workspace/srilm"

You probably did something bad when you modified the makefile on top of that change.

> Now I switch to the TCH shell.

There is no need to change the shell.

> There is a problem with the host name ("unknown"). Is that the real problem? I don't think so, but...

It is not a problem.

> Otherwise, I am getting "make: execvp: /home/gary/workspace/srilm: Permission denied". It looks like a permission problem (which I googled quite a bit). I also tried it with "sudo" but get the same error.

This error is caused by your Makefile modification most likely. Maybe you can try from a clean state again and be more careful.

If you still have your error, share the Makefile with your edits.Also share the build.log which you can create with a command 

     make -d World 2>&1 > build.log

More information about the SRILM-User mailing list