[SRILM User List] Problem installing SRILM

Gary Hess garyhess999 at hotmail.com
Wed Aug 2 00:40:58 PDT 2017

Hi Nickolay,

I ran "make SRILM=$cwd World" and it compiled (suggestion from Andreas Stolcke).

Best regards,


From: Nickolay V.Shmyrev <nshmyrev at yandex.ru>
Sent: Tuesday, August 1, 2017 11:45 PM
To: Gary Hess; srilm-user at speech.sri.com
Subject: Re: [SRILM User List] Problem installing SRILM

01.08.2017, 18:43, "Gary Hess" <garyhess999 at hotmail.com>:
> Hi -- I wonder if anyone can help with my installation problem. I decompressed the file "srilm-1.7.2.tar.gz" in the directory /home/gary/workspace/srilm. In the Makefile, I set "SRILM = /home/gary/workspace/srilm"

You probably did something bad when you modified the makefile on top of that change.

> Now I switch to the TCH shell.

There is no need to change the shell.

> There is a problem with the host name ("unknown"). Is that the real problem? I don't think so, but...

It is not a problem.

> Otherwise, I am getting "make: execvp: /home/gary/workspace/srilm: Permission denied". It looks like a permission problem (which I googled quite a bit). I also tried it with "sudo" but get the same error.

This error is caused by your Makefile modification most likely. Maybe you can try from a clean state again and be more careful.

If you still have your error, share the Makefile with your edits.Also share the build.log which you can create with a command

     make -d World 2>&1 > build.log
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.speech.sri.com/pipermail/srilm-user/attachments/20170802/77335b67/attachment.html>

More information about the SRILM-User mailing list